getting error while including firebase authentication 11.0.1 in android even after updating google repository and services

hey i am getting error while including firebase authentication 11.0.1 in android studio even after updating google repository and services.. my sdk is up to date see screenshot here

compile 'com.android.support:appcompat-v7:25.1.0'
compile 'com.android.support.constraint:constraint-layout:1.0.2'
compile 'com.google.firebase:firebase-database:10.0.1'
compile 'com.google.firebase:firebase-storage:10.0.1'
compile 'com.android.support:recyclerview-v7:25.1.0'
compile 'com.android.support:cardview-v7:25.1.0'
compile 'com.firebaseui:firebase-ui-database:1.1.1'
compile 'com.amulyakhare:com.amulyakhare.textdrawable:1.0.1'
compile 'com.github.bumptech.glide:glide:3.7.0'
compile 'com.android.support:design:25.1.0'
compile 'com.wdullaer:materialdatetimepicker:3.2.2'
testCompile 'junit:junit:4.12'

Blockquote tried using firebase asistant but it is installing 10.0.2