Using PostSharp - There is no Essential License Option in the Dialog

I just upgraded the latest PostSharp version. In the License Popup, i'm not getting the option to use PostSharp Express or Essential?

License Configuration Image

1 answer

  • answered 2017-10-11 10:03 Antonín Procházka

    It means that you already have an Essentials (former Express) license registered. You can see a list of installed licenses in Visual Studio menu PostSharp > Options > License.

    If you don't see the license there or if your build is failing due to licensing, it might be that you have installed the Express license previously for all users. That is not allowed since PostSharp 5. In that case, remove the license from registry HKLM\SOFTWARE\WOW6432Node\SharpCrafters\PostSharp 3\LicenseKey(s) and register the Essentials license in Visual Studio menu PostSharp > Options > License.