Using Robot framework + Selenium with Maven (and no extra installs)?

I've been using Robot Framework with Selenium and having all managed by Maven. But I found out the library I normally use is deprecated. These are the only dependencies in my pom.xml:

<dependency>
      <groupId>org.seleniumhq.selenium</groupId>
      <artifactId>selenium-java</artifactId>
      <version>3.4.0</version>
</dependency>
<dependency>
      <groupId>com.github.markusbernhardt</groupId>
      <artifactId>robotframework-selenium2library-java</artifactId>
      <version>1.4.0.8</version>
</dependency>

And there's also this plugin:

      <plugin>
        <groupId>org.robotframework</groupId>
        <artifactId>robotframework-maven-plugin</artifactId>
        <version>1.4.7</version>
        <executions>
          <execution>
            <goals>
              <goal>run</goal>
            </goals>
          </execution>
        </executions>
        <configuration>
          <includes>
            <include>${robot-tag}</include>
          </includes>
        </configuration>
      </plugin>

The thing is, I want to use the latest Selenium library but I haven't been found a maven dependency for an "official" version of robot framework for java. Is there one? Please keep in mind I don't intend to manually download any libraries. I want the whole thing to be managed by maven.