Build Error: Could not find artifact org.nd4j:nd4j-cuda-9.0:jar:linux-x86_64:0.9.2-SNAPSHOT in sonatype-nexus-snapshots

I'm trying to build the latest DeelLearning4j 0.9.2 using the build-dl4j-stack executable on CentOS workstation. ND4j and Dataved both build with no problem. The DeepLearning4j throws an error at deeplearning4j-cuda module.

[ERROR] Failed to execute goal on project deeplearning4j-cuda-9.0: Could not resolve dependencies for project org.deeplearning4j:deeplearning4j-cuda-9.0:jar:0.9.2-SNAPSHOT: Could not find artifact org.nd4j:nd4j-cuda-9.0:jar:linux-x86_64:0.9.2-SNAPSHOT in sonatype-nexus-snapshots (https://oss.sonatype.org/content/repositories/snapshots) -> [Help 1]

Does anyone knows how to resolve this?

I have CentOS 7 kernel 3.10, nvidia driver 384.81, and Cuda 8.0 installed, and I was able to build DL4j 0.9.2 about 2 months ago with no problem on that system. Is the nd4j-cuda-9.0 jar the nd4j module adapted for cuda 9.0 that I don't have, and I need to upgrade my CUDA to 9.0?

thank a bunch

1 answer

  • answered 2018-01-13 21:53 Adam Gibson

    You can just use our snapshots repo: http://deeplearning4j.org/snapshots

    <repositories> <repository> <id>snapshots-repo</id> <url>https://oss.sonatype.org/content/repositories/snapshots</url> <releases> <enabled>false</enabled> </releases> <snapshots> <enabled>true</enabled> <updatePolicy>daily</updatePolicy> <!-- Optional, update daily --> </snapshots> </repository> </repositories>

    Just use the sonatype oss repo and you'll be fine.

    To future proof this answer, you do not need to build from source 99% of the time. You should double check with the maintainers if you want to build from source. We can help you figure out either the right way to do it or whether you even need to.

    Of note here when using snapshots, you can not use the -platform dependencies like we usually recommend with the stable version.

    You have to use classifiers to properly pick your os as well as specify the nd4j dependencies without a classifier as well (this is due to the native dependencies)